[Grok-dev] Re: grok.View: Self-submitting forms, redirect, and before()

Jegenye 2001 Bt (Miklós Prisznyák) jegenye2001 at jegenye.com
Wed Jan 10 13:32:09 EST 2007

2007/1/10, Philipp von Weitershausen <philipp at weitershausen.de>:
> > Basically, we rename before() to update() and add the semantics that a
> > redirect caused in update() will stop all further rendering.
> Done. It's checked in. I also updated my blog entry:

Hi all,

While I do like the change in semantics, I'm really sorry but I think
"update" is a more confusing name, to me at least, than "before" was
for a method which is executed before the template is rendered.

I'd suggest perhaps "doBefore" or "doBeforeRender" or anything like that.
"Update" doesn't imply at all when this thing is executed, before or
after the show (which must go on, of course :& ).

  Miklós Prisznyák
   Principal Consultant, owner

More information about the Grok-dev mailing list