[Grok-dev] Naming of grok.provides

Thomas Lotze tl at gocept.com
Wed Oct 15 03:18:15 EDT 2008

Philipp von Weitershausen wrote:

>> But even with clearer documentation it's still somewhat confusing? Maybe
>> grok.registers is clearer?
> Or grok.register_for(). Consider this example::
>    class FooBar(grok.GlobalUtility):
>        grok.implements(IBar, IFoo)
>        grok.register_for(IFoo)

I like 'register_for' better as well. How to proceed on this now? Discuss,
write a proposal, just implement it, what about deprecation of the
provides directive? I'm willing to implement the new name if there's
general consent about it.


More information about the Grok-dev mailing list