[Grok-dev] Naming of grok.provides
Philipp von Weitershausen
philipp at weitershausen.de
Wed Oct 15 08:17:55 EDT 2008
Thomas Lotze wrote:
> Philipp von Weitershausen wrote:
>>> But even with clearer documentation it's still somewhat confusing? Maybe
>>> grok.registers is clearer?
>> Or grok.register_for(). Consider this example::
>> class FooBar(grok.GlobalUtility):
>> grok.implements(IBar, IFoo)
> I like 'register_for' better as well. How to proceed on this now? Discuss,
> write a proposal, just implement it, what about deprecation of the
> provides directive? I'm willing to implement the new name if there's
> general consent about it.
If there's a general concensus, I suggest renaming grok.provides to
grok.register_for (this actually has to be done in grokcore.component,
Grok just imports it from there) while keeping it around under the old
name for one or two releases.
More information about the Grok-dev