[Grok-dev] Naming of grok.provides

Thomas Lotze tl at gocept.com
Sat Oct 18 11:47:24 EDT 2008

Christian Theune <ct at gocept.com> wrote:

> register_for doesn't fit the pattern of the current terminology. The
> current names are all declarative,  whereas `register_for` sounds
> imperative. 

Good point. The simplest fix for this seems to be `registered_for',
though I'm not sure I like this since whether the class is actually
registered for the stated interface depends on the way it is processed
by Grok, not until after the programmer has made the declaration.

Maybe a better name can be found in something that simply marks one
interface as the "main" one in some sense, not implying its use for
registration. OTOH this might hurt expressivity.

Could it be that the naming problem is just a symptom of the fact that
the directive is not actually a declaration but a processing


Thomas Lotze · tl at gocept.com
gocept gmbh & co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 0 · fax +49 345 1229889 1
Zope and Plone consulting and development
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.zope.org/pipermail/grok-dev/attachments/20081018/369897c8/attachment.bin 

More information about the Grok-dev mailing list