[Grok-dev] Naming of grok.provides

Philipp von Weitershausen philipp at weitershausen.de
Sun Oct 19 10:01:20 EDT 2008

Christian Theune wrote:
> On Tue, 2008-10-14 at 10:02 +0200, Philipp von Weitershausen wrote:
>> Or grok.register_for(). Consider this example::
>>    class FooBar(grok.GlobalUtility):
>>        grok.implements(IBar, IFoo)
>>        grok.register_for(IFoo)
> register_for doesn't fit the pattern of the current terminology. The
> current names are all declarative,  whereas `register_for` sounds
> imperative. 

Sure, but we have grok.require() as well and that sounds just as 
imperative. I don't think we have to be too anal about finding the right 
grammar for these things if the goal is making their *meaning* more 
obvious. grok.register_for() is by all means better to understand than 
grok.provides(). grok.registered_for() would work too and isn't imperative.

More information about the Grok-dev mailing list