[Grok-dev] Naming of grok.provides

Thomas Lotze tl at gocept.com
Thu Oct 23 02:57:30 EDT 2008

Philipp von Weitershausen wrote:

> Sure, but we have grok.require() as well and that sounds just as
> imperative. I don't think we have to be too anal about finding the right
> grammar for these things if the goal is making their *meaning* more
> obvious. grok.register_for() is by all means better to understand than
> grok.provides(). grok.registered_for() would work too and isn't
> imperative.

Taking into account all that's been said in this thread, I'm now
personally in favor of "register_for" and given the absence of further
objections, will implement it as soon as possible.


More information about the Grok-dev mailing list