[Grok-dev] Naming of grok.provides

Jan-Wijbrand Kolman janwijbrand at gmail.com
Thu Oct 23 03:12:01 EDT 2008

On Thu, Oct 23, 2008 at 8:57 AM, Thomas Lotze <tl at gocept.com> wrote:
> Philipp von Weitershausen wrote:
>> Sure, but we have grok.require() as well and that sounds just as
>> imperative. I don't think we have to be too anal about finding the right
>> grammar for these things if the goal is making their *meaning* more
>> obvious. grok.register_for() is by all means better to understand than
>> grok.provides(). grok.registered_for() would work too and isn't
>> imperative.
> Taking into account all that's been said in this thread, I'm now
> personally in favor of "register_for" and given the absence of further
> objections, will implement it as soon as possible.

(Sorry for the late reponse)

What's your take on Kit's "registers_for" suggestion? I'd be in favor
of that. Not being religious about it though.


Jan-Wijbrand Kolman

More information about the Grok-dev mailing list