[Grok-dev] Naming of grok.provides

Sebastian Ware sebastian at urbantalk.se
Thu Oct 23 03:33:22 EDT 2008

Who wants to bet that people will continuously misspell registers_for  
as register_for... :) (or start misspelling grok.require as  

Mvh Sebastian

23 okt 2008 kl. 09.12 skrev Jan-Wijbrand Kolman:

> On Thu, Oct 23, 2008 at 8:57 AM, Thomas Lotze <tl at gocept.com> wrote:
>> Philipp von Weitershausen wrote:
>>> Sure, but we have grok.require() as well and that sounds just as
>>> imperative. I don't think we have to be too anal about finding the  
>>> right
>>> grammar for these things if the goal is making their *meaning* more
>>> obvious. grok.register_for() is by all means better to understand  
>>> than
>>> grok.provides(). grok.registered_for() would work too and isn't
>>> imperative.
>> Taking into account all that's been said in this thread, I'm now
>> personally in favor of "register_for" and given the absence of  
>> further
>> objections, will implement it as soon as possible.
> (Sorry for the late reponse)
> What's your take on Kit's "registers_for" suggestion? I'd be in favor
> of that. Not being religious about it though.
> regards,
> jw
> -- 
> Jan-Wijbrand Kolman
> _______________________________________________
> Grok-dev mailing list
> Grok-dev at zope.org
> http://mail.zope.org/mailman/listinfo/grok-dev

More information about the Grok-dev mailing list