[Grok-dev] proposal: splitting up View from PythonView

Philipp von Weitershausen philipp at weitershausen.de
Wed Sep 17 04:30:49 EDT 2008

Martijn Faassen wrote:
> Sebastian Ware wrote:
>> How about "grok.SimpleView" which logically would be less specialised  
>> than "grok.View".
> No, 'Simple' is never the right word for a class, as it's unlikely to be
> true. :)

Indeed. Faassen's law states:

   Nomen simplex est omen contrarium

meaning that anything in Zope containing the word "simple" is actually 
quite horrible and complicated (cf. SimpleItem, SimpleViewClass, etc.).

(P.S.: Using grok.View for template-based views makes a lot of sense to 
me because the template essentially describes the "view" whereas pure 
Python-based views are more like controllers in other frameworks.)

More information about the Grok-dev mailing list