[Grok-dev] proposal: splitting up View from PythonView
faassen at startifact.com
Wed Sep 17 06:43:28 EDT 2008
Philipp von Weitershausen wrote:
> Martijn Faassen wrote:
>> Sebastian Ware wrote:
>>> How about "grok.SimpleView" which logically would be less specialised
>>> than "grok.View".
>> No, 'Simple' is never the right word for a class, as it's unlikely to be
>> true. :)
> Indeed. Faassen's law states:
> Nomen simplex est omen contrarium
> meaning that anything in Zope containing the word "simple" is actually
> quite horrible and complicated (cf. SimpleItem, SimpleViewClass, etc.).
Cool, in Latin no less. "A simple name is an omen of the contrary". :)
More information about the Grok-dev