[Grok-dev] Catalog/Indexes/Search error

Kathy Manwaring kathy at perfectnotes.com.au
Wed Dec 30 18:37:19 EST 2009

Hi Sebastian and Tim,

I have done as you documented below, but it still breaks. Note that I am
running Windows (although that should not make any difference...)

My steps:

1. Create project as per Step 1 below.
2. Modify setup.py as per Step 2 below.
3. Run bin\buildout, changing versions until all pass requirements.
(versions.cfg file attached)
4. Changed app.py and index.pt as per Sebastian's file. Added
interfaces.py and protonobject.py from Sebastian's file.

At this point, on attempting to start the server, I got errors. The first
were basic, in that you had characters which are not supported by my
keyboard in the 'chars' variable, so I removed them. This still left one:
zope.configuration.config.ConfigurationExecutionError: <class
'martian.error.GrokError'>: View <class 'timsearch.app.ProtonSearch'> has
no associated template or 'render' method
So I added an empty render method to ProtonSearch class:
    def render(self):

This allowed the project to start.

But when I tried to create an instance, I got 'A system error occurred.'

And the traceback ends with the same error that appears every time:

ComponentLookupError: (<InterfaceClass zope.app.intid.interfaces.IIntIds>,

(The full transcript of how it got there is on my original message).


> I have modified your code with search and add objects just to try it.
> It seems to work perfectly.
> 1 created project
>    bin/grokproject TimSearch --zopectl
> 2 Modified setup.py to add install_requires
>       'zc.catalog',
>       'hurry.query'
> 3 ran
>    bin/buildout
> 4 added the following code files and page templates
> 5 Started the project and created the instance of the application
> Now you can do:
>    http://localhost:8080/test/addobjects
> to add 10 objects. Then try
>    http://localhost:8080/test/protonsearch?search=where
> to search and return the text index results.
> Mvh Sebastian
> 30 dec 2009 kl. 02.46 skrev Tim Cook:
>> <proton.txt>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: versions.cfg
Type: application/octet-stream
Size: 3512 bytes
Desc: not available
Url : http://mail.zope.org/pipermail/grok-dev/attachments/20091231/29616771/attachment.obj 

More information about the Grok-dev mailing list