[Grok-dev] Installing 0.14.1 on Windows XP

Jeroen Michiel jmichiel at yahoo.com
Tue Jan 6 07:03:49 EST 2009

I'm trying to get Grok 0.14.1 running on Windows XP, but ran into quite some
I wanted to use a virtual environment, as I'm using python for other things
as well.
So I did the virtualenv thing with --no-site-packages to be completely
independent of my normal python install (would this indeed be the case?)

Everything went smoothly until I tried to create a grokproject:

First problem I ran into, was that it seems precompiling the py files has
problems with spaces in directory names: when I did 'grokproject myproject',
it started throwing errors by the dozen at me in py_compile.py that it
couldn't find the file specified, referring to 'c:\\documents'. I suspect
that it was trying to precompile the .py files in the buildout eggs, which,
by default seem to end up somewhere in 'c:\\Documents and
So I retried with the option --eggs-dir set to a non-spaced dir (in my
virtual environment dir, for the record, so everything's at 1 place. Perhaps
not a good idea?). This seemed to work.

Until I ran into the second problem:
zope.app.testing wouldn't install correctly.
I searched this very forum, and found this:
which solved it (for the record: editing the download.py in
z3c.recipe.eggbasket and changing 'w' to 'wb' on line 46)

On to the next problem: OSError :Permission denied
This seems to be a problem with Python not being able to remove temp dirs on
windows, but it left me clueless as whether the rest of the install was
successful or not... So I ran the script again, but that didn't seem to
install anything new, so I assumed the temp dir removal problem didn't break
the installation

I also noticed a few 'warnings': 
* case sensitivity problems ZConfig caused installation of distribution
zconfig with a different name.
* a few 'module references __file__' messages: are these warnings???

Now installation was done, let's try running zopectl
The tutorial states to run 'zopectl fg', without any explanation what this
fg exactly means? seems to be necessary, though! A little explanation could
help here...

Running zopectl however, gave me my next problem, which resulted in doing
things all over again:
import win32api fails...
It seems you need the PyWin32 package. This isn't mentioned anywhere (and I
know others have already complained about it apparently, but it still isn't
No problem I thought, get it and install it. Only, the install is a windows
installer which insists on having your python registered in windows. My
virtual enviroment ISN'T, so I can't install it there. Installing it in the
original python install doesn't help, as I used --no-site-packages to create
my virtual environment. I know there's a way to also register this virtual
environment to windows, but know how from the top of my head, so I recreated
my virtual env without the switch, hoping that it would copy the
sitepackages to the new env, but it didn't, it just added the site-packages
of the original python install to the path (or something like that), which
makes the env dependent on the original python install, which I didn't want
in the first place...
So I left it like that, and got it running now, but boy, what a journey!

I think it's a pity that it isn't working on Windows right out of the box,
or at least well-documented how to get it working, because it will put off a
lot of beginners. But I really want to use grok (and Zope3), because I know
it's very powerful, but not everyone does!

This post is in no way meant as a rant. I just want to help out other
newbies, who might have run into the same problems, but quit because of

Have I done anything stupid here (because I didn't know enough)?

View this message in context: http://www.nabble.com/Installing-0.14.1-on-Windows-XP-tp21309146p21309146.html
Sent from the Grok mailing list archive at Nabble.com.

More information about the Grok-dev mailing list