[Grok-dev] 1.01a install trouble on Windows Vista

Martijn Faassen faassen at startifact.com
Tue Jan 13 13:28:05 EST 2009

Seb F-S wrote:
>>  (see
> http://www.nabble.com/Installing-0.14.1-on-Windows-XP-tt21309146.html) 
> Here’s what I did :
> In
> C:\Users\Seb\.buildout\eggs\z3c.recipe.eggbasket-0.4.0-py2.5.egg\z3c\recipe\eggbasket,
> I edited downloder.py on line 46 this way :
>                 tarball = open(temp_tarball_name, 'wb')
> I erased bytecode 'downloader' files.
> I went to my c:\Python25\Scripts\sebsgrokproject1 and ran \bin\buildout.exe
> and it's been getting distributions ... until I ran again into a number 32
> error.

The errors concerning eggbasket *should* be gone with the latest release 
of eggbasket. Could you remove your .buildout directory (including eggs) 
and try grokproject again?

> And now on with the tutorial
> (http://grok.zope.org/doc/current/tutorial.html#starting-up-zope)
> I ran '\bin\paster serve etc\deploy.ini' in the newly created
> "sebsgrokproject1" folder gives a 10013 socket error :
> http://www.nabble.com/file/p21440996/ScreenHunter_04%2BJan.%2B13%2B18.55.gif 

A permission denied error when trying to open the socket. This one seems 
new to me. Anyone have a clue what's going on here? Perhaps Vista 
doesn't want to open sockets as some form of security precaution? Must 
be a way around it.



More information about the Grok-dev mailing list