[Grok-dev] grok z3c.testsetup problem

Christian Klinger cklinger at novareto.de
Thu May 7 10:28:10 EDT 2009


i run into a testing problem. This is my scenario:

I have a grokproject called training. In the src
package of training i have a new python package
called nva.sliteauth. I have added nva.sliteauth to
setup.py install_requires and buildout´s development

In the sliteauth a have a module called
tests.py with this content:

import z3c.testsetup
import nva.sliteauth
test_suite = z3c.testsetup.register_all_tests('nva.sliteauth') 

and a README.txt with this simple test.

Test fuer nva.sliteauth
   >>> import pdb; pdb.set_trace()
   >>> 1 + 1

Now if i run bin/test -s nva.sliteauth i got these message:

yeti:training cklinger$ bin/test
Test-module import failures:

Module: nva.sliteauth.nva.sliteauth.tests

ImportError: No module named nva.sliteauth.tests

Running tests at level 1

Test-modules with import problems:
Total: 0 tests, 0 failures, 0 errors in 0.000 seconds.

Has anyone an idea where my error is?
Thanks in advance

### Package Structure ###

More information about the Grok-dev mailing list