[Grok-dev] Problem with megrok.chameleon

Rob Campbell kg6hum at gmail.com
Sat Apr 9 23:22:13 EDT 2011


Thank you for the reply.  I wasn't trying to use Chameleon 2.0, that
was just what buildout decided to download.  Was I doing something
incorrectly when I just added megrok.chameleon to my setup.py?  I
would have thought that buildout would handle retrieving the correct
versions of dependencies.

I am new to Grok and buildout, so if I am doing something wrong I
would like to correct it.

Rob Campbell

On Fri, Apr 8, 2011 at 7:11 PM, Souheil CHELFOUH <trollfot at gmail.com> wrote:
> Chameleon 2.0rc7 doesn't work with megrok.chameleon
> You need to pin a version in the 1.x serie.
> If you want to use Chameleon 2.0, dolmen.template is being cooked and
> already works
> 2011/4/8 Rob Campbell <kg6hum at gmail.com>:
>> Hello,
>> I have been having problems getting megrok.chameleon to work with Grok
>> 1.4.  I created a new grok project and added 'megrok.chameleon' to
>> install_requires in setup.py.  I ran bin/buildout which found
>> megrok.chameleon 0.5.2 and Chameleon 2.0-rc7.  When I run bin/paster
>> serve parts/etc/deploy.ini I get a traceback about not being able to
>> find chameleon.genshi.template.
>> Is this a known problem?  Is it a conflict between certain versions of
>> Grok and megrok.chameleon?
>> --
>> Rob Campbell
>> _______________________________________________
>> Grok-dev mailing list
>> Grok-dev at zope.org
>> https://mail.zope.org/mailman/listinfo/grok-dev

More information about the Grok-dev mailing list