[Grok-dev] megrok.rdb setup error

Christian Schmidt grok-list at creativenet.de
Fri Jun 1 12:22:08 UTC 2012

Today I ran into the same problem. The suggested pinning was not working 
an so i tried to figure out the problem.

collection is part of sqlalchemy. In versions >= 0.7 'in_link' has 
disapeared. This breaks megrok.rdb 0.12.

/megrok/rdb/components.py line 62:


I pinned sqlalchemy to version 0.6.9

buildout.cfg or versions.cfg:


ran bin/buildout and anything was fine.

Finally I hope that there is somebody who is able to make megrok.rdb 
compatible with newer versions of sqlalchemy.

hope that this a solution for you.


>> File
>> "/home/usytis/.buildout/eggs/megrok.rdb-0.12-py2.7.egg/megrok/rdb/components.py",
>> line 62, in Container
>> @collection.on_link
>> zope.configuration.xmlconfig.ZopeXMLConfigurationError: File
>> "/home/usytis/second/parts/etc/site.zcml", line 4.2-4.30
>> ZopeXMLConfigurationError: File
>> "/home/usytis/second/src/second/configure.zcml", line 4.2-4.37
>> AttributeError: type object 'collection' has no attribute 'on_link'
>> If I try with sqlalchemy it works!
>> Thanks a lot!_______________________________________________
>> Grok-dev mailing list
>> Grok-dev at zope.org
>> https://mail.zope.org/mailman/listinfo/grok-dev

More information about the Grok-dev mailing list