[ZDP] BackTalk to Document Zope Developer's Guide (2.4 edition)/Components and Interfaces

nobody@nowhere.com nobody@nowhere.com
Fri, 13 Sep 2002 19:12:01 -0400


A comment to the paragraph below was recently added via http://www.zope.org/Documentation/Books/ZDG/current/ComponentsAndInterfaces.stx#2-3

---------------

    Let's take a look at this step by step.  Here, you see two Python class
    statements.  The first statement creates the *interface*, and the
    second statement creates the *implementation*.

      % Anonymous User - Dec. 5, 2001 6:46 am - In scripts you only use instances of the implementation class, in this case HelloComponent. Perhaps it would be good for educational purposes to add an __init__ as well to HelloComponent. Or refer to chapter 3 for the use.

      % Anonymous User - Dec. 12, 2001 2:57 pm - Not comment really, but question.   Where I find the Interface module. I can't with myself. Not at my filesystem nor at my ZOPE. I'd  like to do practice also with this tutorial.

      % Anonymous User - Dec. 13, 2001 10:18 am - {ZOPEHOME}/lib/python/Interface

      % jshell - Jan. 24, 2002 12:56 pm - This should all be updated to reflect where interfaces are going for Zope 3.  First, the interface should be named "IHello", and there should be no 'self' in the signature for the 'hello()' method.

      % Anonymous User - July 11, 2002 12:44 pm:
       Where can I find more info regarding Zope 3? I realize that it is a work-in-progress.

      % Anonymous User - Aug. 8, 2002 11:58 pm:
       Get rid of the 'self' param/sig?.., yeh! This is one thing I've found distasteful in my wonderings/wanderings
       thru zope. Now lets consider the double underscores. Javascript seems more elegant/simple and widespread, imo
       - it WILL be on the client...why learn both? I'd use zope 'for real' if that were the case.

      % Anonymous User - Sep. 13, 2002 7:12 pm:
       The reason for 'self' is so that one can distinguish between class and instance
       methods in Python.  Unlike Java, Python does not have a 'static' keyword to
       describe class methods.