[Zodb-checkins] CVS: ZODB/src/ZODB/FileStorage - FileStorage.py:1.4

Jeremy Hylton jeremy at zope.com
Tue Feb 17 20:13:32 EST 2004


Update of /cvs-repository/ZODB/src/ZODB/FileStorage
In directory cvs.zope.org:/tmp/cvs-serv25077/src/ZODB/FileStorage

Modified Files:
	FileStorage.py 
Log Message:
Rename transactionalUndo() to undo().

The old undo was not used by Zope and shouldn't have been used by any
other client.  The newly named undo() is the preferred version of
undo.

XXX DemoStorage didn't implement transactionalUndo, so now it doesn't
implementation undo() at all.  We need to replace it with the demo
storage from ZODB4.

There are a few changes related to ZODB4 removal in this checkin.


=== ZODB/src/ZODB/FileStorage/FileStorage.py 1.3 => 1.4 ===
--- ZODB/src/ZODB/FileStorage/FileStorage.py:1.3	Mon Dec 29 17:40:49 2003
+++ ZODB/src/ZODB/FileStorage/FileStorage.py	Tue Feb 17 20:13:00 2004
@@ -1076,7 +1076,7 @@
         finally:
             self._lock_release()
 
-    def transactionalUndo(self, transaction_id, transaction):
+    def undo(self, transaction_id, transaction):
         """Undo a transaction, given by transaction_id.
 
         Do so by writing new data that reverses the action taken by




More information about the Zodb-checkins mailing list