[Zope-DB] Inquring Minds Want to Know

Haden Peterson hadenpeterson@yahoo.com
Fri, 23 Nov 2001 14:51:58 -0800 (PST)

I seem to be missing some key point along the road to
installation enlightenment - re:to connect to Oracle
w/ Python.(Not trying to connect through Zope...yet.)

In a Win32 environment, I've unzipped DCO2-Beta5.zip
which extracts as zoracleda\...
and tried to run a test script by using the following:


I get a popup window complaining that python15.dll
can't be located in any of the search directories on
my path - which is right, but puzzling since the
version of .dll that came with my distribution is

I tried re-naming the ZOracleda directory to DCOracle2
as indicated in the README.


Here I get - "No module named DCOracle2.dco2" - which
would seem to indicate that Python can't find it - a
path problem. I'm assuming that it's looking for the
file named dco2.pyd that lives in DCOracle2\DOracle2.
Or does it expect a .py file?

Do I have to have a PYTHONPATH environment var set to
point to this file?
(I've tried it along with including it in regular PATH
but without success.)

Do I need to build a binary or is this file (dco2.pyd)
the binary it's looking for? I tried running nmake
against the makefile in the top level (ZOracleDA)
directory, but it didn't understand the one of the

If you've been through this already - I'd be most


Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.