[Zope-DB] Re: Problem with Psycopg?

Stylus zope@stylusinc.net
Wed, 26 Jun 2002 19:15:18 +0530

Hi Derrick,
Please refer to my recent email posting to this list. I have tried the
rebuild of psycopg by explicitly using Python-2.1 (I downloaded and
installed Python-2.1.3 in /usr/Python-2.1.3 and then I used the
following command -

./configure --with-postgres-libraries=/usr/lib
ateTime/mxDateTime --with-zope=~/Zope-2.5.1
--with-python=~/Zope-2.5.1/bin/python --with-python-version=2.1

and I still get the following error
./config.status:~/Zope-2.5.1/bin/lib/python2.1/config/makesetup: No such
file or directory

I am not sure about how to modify the setup.py script - any pointers ?
Do I need to do that even with the above options that I pass to


-----Original Message-----
From: zope-db-admin@zope.org [mailto:zope-db-admin@zope.org] On Behalf
Of Derrick 'dman' Hudson
Sent: Wednesday, June 26, 2002 5:21 PM
To: zope-db@zope.org
Subject: [Zope-DB] Re: Problem with Psycopg?

Rebuild psycopg (and mxDateTime) but build them against python 2.1, not
2.2.  You may need to modify the setup.py script to point it to the
right 'python' interpreter.  (the fact that the modules were installed
in the "wrong" place indicates that something is "wrong" with your setup
-- the modules were build and installed just fine for python 2.2)
You'll definitely need the (C) headers from python 2.1 to compile.  I
don't know if zope's tarball comes with them or not.

I really can't help other than pointing out that problem because I have
pre-made packages for my distro that work quite well.



If Microsoft would build a car...
... Occasionally your car would die on the freeway for no reason. You
would have to pull over to the side of the road, close all of the car
windows, shut it off, restart it, and reopen the windows before you
could continue. For some reason you would simply accept this.