[Zope-DB] Problem with Psycopg?

Stylus zope@stylusinc.net
Thu, 27 Jun 2002 13:28:31 +0530

Hi Dieter,

I finally figured out how to get and install the python2.1 development package and was able to run the ./configure command correctly using the following command :
./configure --with-postgres-libraries=/usr/lib --with-postgres-includes=/usr/include --with-mxdatetime-includes=/usr/lib/python2.1/site-packages/mx/DateTime/mxDateTime --with-zope=~/Zope-2.5.1 --with-python=/usr/bin/python2.1 --with-python-version=2.1 --with-python-exec-prefix=/usr

It went through fine but I get the following error when I run 'make' :
./module.o ./connection.o ./cursor.o ./typeobj.o ./typemod.o  -L/usr/lib -lpq  -o ./psycopgmodule
make: execvp: ./module.o: Permission denied
make: *** [psycopgmodule] Error 127

Stuck again - I tried giving module.o +x permissions but it gives me a similar error :
make: execvp: ./module.o: cannot execute binary file
make: *** [psycopgmodule] Error 126

I tried as root also - no difference - any ideas ?


On Wed, 26 Jun 2002 21:40:31 +0200
Dieter Maurer <dieter@handshake.de> wrote:

> Stylus writes:
>  > I run the following command -
>  > ./configure --with-postgres-libraries=/usr/lib --with-postgres-includes=/usr/include --with-mxdatetime-includes=~/Zope-2.5.1/lib/python2.1/site-packages/mx/DateTime/mxDateTime --with-zope=~/Zope-2.5.1 --with-python=~/Zope-2.5.1/bin/python --with-python-version=2.1 --with-python-prefix=/usr/Python-2.1.3
>  > 
>  > and I get the following error
>  > ./config.status:~/Zope-2.5.1/bin/lib/python2.1/config/makesetup: No such file or directory
> You need to install the Python development package...
> Dieter