[Zope-DB] HEEELP! my zope has become virtually unusable

Tena Sakai tena.sakai.b@bayer.com
Wed, 2 Apr 2003 11:13:15 -0800


My zope (Zope-2.5.1-solaris-2.6-sparc) has become virtually unusable.

The peculiar behavior is that it takes forever to respond.  Maybe that
doesn't sound peculiar enough?  Please read on.

It has been going on for sometime, but last a day or so it became
unbearably slow.  The problem appears that it is unable to update
icons on client machines.  This morning, I stop'ed and (re-)start'ed
it on the server and when I logged on from a browser (mozilla) it gave
me an authentication dialog prompt instantly, but then the it took 17+
minutes for the right-hand side window to get painted.  (It worried me
sick!)  The left-hand side window (where it lists the "file structure"
iconically), I don't even know how long it took, but eventually it finished
showing icons.

I was watching Z2.log file in var directory (via "tail -f") and it showed
nothing at all for those 17+ minutes.  (I redirected start log and there
is nothing peculiar in it.)  And all of a sudden, the icons got painted
on the client machine and I noticed that a bunch of lines got into Z2.log
file.  The server load is very low, load average is in the neighborhood
of 0.02.  As I tried to "open" a folder from left-hand side window by click-
ing on a plus sign, it stalled again.  I stopped the request from browser's
stop button and then clicked on reload; it was able to show me contents
of that folder (instantly).  This "trick" has worked in the past, except last
a day or so it refused to cooperate.  I have tried with mozilla as well as
IE, but they seem to have the same behavior.  I have tried things from
different clients; there is little difference.

I want to point a finger at network because that's one place I have no
control.  (Sorry about this unacceptable trait of mine:)  But the usual stuff
(ping, telnet, ftp, etc) to and from the server all work.

Now I am able to go to /control_Panel/Database.  In fact, I am looking
at info under Cache Parameters tab:
      Total number of objects in the database: 10561
      Total number of objects in all caches: 2294
      Target size: 400
      Target max time between accesses: 60

Do they (bottom two, in particular) look reasonable?  Please tell me
what they mean or what they should be like.  And what are the units on
these?  MB, KB?, seconds?, miliseconds?

Sorry for being verbose, but I am trying to put things on the table as
much as possible now.

Thank you.

Tena Sakai (tena.sakai.b@bayer.com)