[Zope-DB] DCOracleStorage "read buffer" error

Randy Yarger ryarger at webelite.com
Mon Aug 11 19:08:19 EDT 2003


I've been using DCOracleStorage for a fairly large production website for close to a year now with very few problems. One problem has been dogging me since the beginning though and it's time to seek help. When I do any large operation that require a great deal amount of data transfer from the database, the operation frequently dies with this exception:

Expected read buffer, None type found.

The error comes from the Connection class (Don't have the exact line number at the moment but can recreate it fairly easily).

This error is *not* consistent, but it is frequent. The full exception includes the object that triggered the exception in the 'Info' field and it is a differnt object each time.

This occurs most frequently when I attempt to re-index the Catalog for the site. I generally have to re-run it four or five times (or more) before the operation completes. I thought it might be a Catalog-specific error but I just got the same error when trying to export the entire site (the export worked on the second try).

Any seen this before or have any other ideas?

-Randy Yarger
randy at yarger.net

P.S. What are the current trends in RDBMS Storages? Is APE going to be a standard or is DCOracleStorage sticking around?

More information about the Zope-DB mailing list