[Zope-DB] DCOracle2 problem

Matthew T. Kromer matt@zope.com
Mon, 05 May 2003 14:57:51 -0400

Gor - wrote:

> The stored procedures aren't doing anything "weird", python would 
> crash with any stored proc.  I tried installing Zope on a Linux box 
> (now with DCOracle 1.3b), and received segmentation faults when I 
> attempted to edit any stored proc.
> I then tried using another oracle user that was not the owner of any 
> stored procs or packages.  That second user was able to 
> create dcoracle2 stored procedures using stored procedures from the 
> first user's schema.  The only problem was that when editing the 
> dcoracle2 stored procedure, the second user had no known user-defined 
> procedures, so the edit would fail because the drop down was empty.  I 
> added a stored procedure to the second user's schema to get around this.
> I experienced a segmentation fault again when I added a package 
> containing a procedure to the second user's schema and then tried to 
> edit a dcoracle2 stored procedure.
> Has anyone experienced any problems with packages containing procedures?
> Thanks,
> Eric

Is this behavior purely under windows?

In any case, the only suggestion I have is to enable DCO2 tracing to 
identify what about the requests causes a crash.

It is possible that the problem only surfaces on Windows; I do only 
minimal Windows testing to make sure that the compiled module loads and 
don't try to do anything sophisiticated.

Matt Kromer
Zope Corporation  http://www.zope.com/