[Zope-DB] Database Adaptor for Oracle 9i

Sidnei da Silva sidnei@x3ng.com
Thu, 15 May 2003 16:41:47 -0300

On Thu, May 15, 2003 at 02:34:21PM -0400, Matthew T. Kromer wrote:
| Rima Gerhard wrote:
| >I am really sorry if this have been asked before, but I couldn't find 
| >any info on this subject at all. My department just updated to Oracle 
| >9i from 8i. I was using DCOracle2 for Oracle 8i and everything worked 
| >fine, but ever since they have upgraded, I cannot use DCOracle2 any 
| >more. Does anybody know how to fix this or know of another product 
| >that I could use?
| >Thanks a lot!
| >-rima.
| >
| If you can build from source, just rebuild DCOracle2 against oracle 9i 
| libraries.  It should work just fine.

I know that this may sound like a stupid thing to do, but recently I
installed DCOracle on a server where I had the 9i client installed,
but for some reason, they installation didnt had oci.h. Trying to
install the binary DCOracle, it was looking for a file named
libclntsh.so.8.0, and obviously it wont find. Then I linked
libclntsh.so.9.0 to libclntsh.so.8.0 and it apparently worked.

Now, my question: how much trouble can I get into by doing this? :)

Sidnei da Silva (dreamcatcher) <sidnei@x3ng.com.br>
X3ng Web Technology <http://www.x3ng.com.br>
GNU/Linux user 257852
Debian GNU/Linux 3.0 (Sid) 2.4.18 ppc

Nothing happens.