[Zope-DB] Problem installing zodbca ODBC driver

George Perry PerryG@esi.com
Wed, 21 May 2003 09:11:33 -0700


Thank you for your suggestion.

After I sent my previous request for help, my poking around convinced me
that I needed to delete the ZODBCDA product through the Zope interface as
well as simply deleting and replacing the files installed by

I tried the following:
  1) deleting the files (at the MSWin command line)
  2) deleting the product (via Zope/manage interface)
  3) stopping the zope service on my MSWin2K workstation
  4) redownloading the ZODBCDA-3.1.0b2-win32-py21.tgz file from zope.org
  5) reinstalling the ZODBCDA package (via Cygwin's tar at the MSWin command
  6) restarting the zope service

I still don't see any evidence that the installation was successful:
  1) I do not see any ODBC object in the Add drop down list
  2) I still see the Import Traceback message in the Control_Panel|ZODBCDA

Charlie Clark was also kind enough to respond to my request for help,
suggesting that I try the ZmxODBC product.  I believe that this is a
commercial/proprietary product.  I am afraid that I would have a hard time
convincing my boss to spend approximately $100 so I can evaluate something
that is supposed to be free, but which I am unable to get running.

Is there any chance that you could e-mail me the copy of
ZODBCDA-3.1.0b2-win32-py21.tgz that you were able to get to work?

If there is some other intuitively obvious step I should be taking, but am
missing - please advise.

Thank you,
George Perry

Electro Scientific Industries
13900 NW Science Park Drive
Portland, OR  97229-5497
(503) 671-5234

-----Original Message-----
From: McDonnell, Larry [mailto:lmcdonnell@protonenergy.com]
Sent: Wednesday, May 21, 2003 5:10 AM
To: George Perry; 'zope-db@zope.org'
Subject: RE: [Zope-DB] Problem installing zodbca ODBC driver


Is this at startup? If it is try to download the adapter again. I was trying
to load ZMysql adapter for days until I sent it to someone else and they had
the same problem. I download a fresh version and everything can up. Just to
let you know I have the same set up here at work (w2k, 2.6.1, and ZODBC

-----Original Message-----
From: George Perry [mailto:PerryG@esi.com]
Sent: Tuesday, May 20, 2003 7:46 PM
To: 'zope-db@zope.org'
Subject: [Zope-DB] Problem installing zodbca ODBC driver

I am a ZOPE newbie, so please have patience with me.

Yesterday I installed Zope on my MSWin2K workstation, using the
Zope-2.6.1-win32-x86.exe installation file from zope.org.  It seems to be
running as expected.  Here is the version info from the Zope Control_Panel
Zope Version
(Zope 2.6.1 (binary release, python 2.1, win32-x86), python 2.1.3, win32)
Python Version
2.1.3 (#35, Apr 8 2002, 17:47:50) [MSC 32 bit (Intel)]
System Platform
I tried to install the ZODBCA ODBC driver, which I also downloaded from
zope.org.  The installation seemed to have gone properly, with the files
ending up in:
 <ZOPE DIR>\lib\python\products\zodbcda

I was expecting to be able to add a ODBC object from the Add widget in the
root folder.  I did not see any appropriate entry to do this.  

In the Zope Control_Panel|Products|ZODBCDA tree, I see the following:
Import Traceback

Traceback (most recent call last):
  File "C:\PROGRA~1\SandBox\lib\python\OFS\Application.py", line 541, in
    product=__import__(pname, global_dict, global_dict, silly)
  File "C:\PROGRA~1\SandBox\lib\python\Products\ZODBCDA\__init__.py", line
91, in ?
    import DA
  File "C:\PROGRA~1\SandBox\lib\python\Products\ZODBCDA\DA.py", line 92, in
    from db import DB, manage_ODBCDataSources
  File "C:\PROGRA~1\SandBox\lib\python\Products\ZODBCDA\db.py", line 86, in
    from sql import *
ImportError: DLL load failed: Access is denied.
The ZODBC download page on zope.org states that I need to use the proper
version.  Just to be safe, I have tried both version 3.1.0b2 files (deleting
the installation directory between installs.

Thanks in advance for any insight about what I need to do differently.

Thank you,
George Perry

Zope-DB mailing list