[Zope-DB] DCOracle2 Woes

Matthew T. Kromer matt@zope.com
Wed, 21 May 2003 13:02:36 -0400

Norfleet, Sheppard S. wrote:

>      python 2.1.3
>      Zope 2.6.1
>      DCOracle2 (tried both 1.2 and 1.3b)
>      Oracle 9i (9.0.1)
>      RedHat 8.0 linux
>      After building both versions of DCOracle2 I 
>      attempt to run install.py which fails with: unresolved symbol:
>__cmpdi2 in libclntsh9.so. I think the symbol issue actually traces back
>      to libgeneric9.a but not sure if it matters anyway. The binaries
>provided for redhat 7.1 also fail in the same way.
>      I attempted to get around this by installing oracle 8.1.6 just to make
>the install.py work, and it does. 
>      But when I switch my oracle home back to 9i and attempt to connect to
>the 9i database I get a ORA-01821 Date format error of some
>      sort, which is extremely wacky.
>      I have been searching for weeks to find a solution. If anyone has any
>ideas I would be greatly apprecitive.
>      thanks 
>      shep 
>Zope-DB mailing list

Hi Shep,

This is actually an Oracle problem, because Oracle is expecting a RedHat 
7 system, most likely.

If you look at how the Perl DBI folks do it:

you'll see that Oracle is linked against specific libc builds, which 
newer RedHats break.

You can either download a new Oracle install (maybe!) or trying the 
build instructions in that thread to rebuild libclntsh.so.

I was able to follow the instructions (but using gcc 3.2.2 for RedHat 9) 
and rebuild libclntsh.so so that DCOracle2 worked on my RedHat 9 system.

Matt Kromer
Zope Corporation  http://www.zope.com/