[Zope-DB] DCOracle2: ORA-06502: PL/SQL: numeric or value error: character string buffer too small

John Ziniti rejpz at channing.harvard.edu
Thu Dec 9 10:17:53 EST 2004

Thanks for your response, Matt.

Matthew T. Kromer wrote:
> What I think you want to try is to set the output size on the cursor 
> with a cursor.setoutputsize(column, size)  -- I *think* you can then 
> pick up a procedure bound to that cursor by using cursor.findproc but I 
> don't see the cursor substitution code.

I'll ignore this suggestion for now given your comments below, but let
me know if you think I should revisit this option.

>  This code is old and very gross right now.  It appears that if you pass 
> in a bindingarray to the stored procedure it gets passed through, so you 
> shouldn't need to do what I just said.  I haven't worked with the 
> codebase in about a year and a half and this section of the python 
> bindings was always very gross to me; I just never fixed it.
> Its likely I'll need to see the DCO2TRACEDUMP to look at the bind, to 
> make sure the size was actually set up right to Oracle.

I'll attach the DCO2TRACEDUMP (zipped, as I feel icky attaching a 43K
text file to an email ... let me know if you don't like the zip).  Hope-
fully you can find some time to check it out.

Thanks a million,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: dco2dump.zip
Type: application/zip
Size: 3749 bytes
Desc: not available
Url : http://mail.zope.org/pipermail/zope-db/attachments/20041209/7d89efa7/dco2dump.zip

More information about the Zope-DB mailing list