[Zope-DB] DCOracle2: ORA-06502: PL/SQL: numeric or value error: character string buffer too small

Matthew T. Kromer matt at bane.mi.org
Fri Dec 10 18:07:42 EST 2004

Hehe, well, re-writing the entire DCOracle2 package based around a  
slightly better appreciation of "how to do it" has kind of been on the  
back-burner for a few years.  I don't get paid to do this sort of thing  
anymore, and ... (excuses, excuses).  The C layer isn't in terrible  
shape, but most of the python layer (especially in the stored procedure  
discovery and invocation areas) is a pile of hackish procedural code.   
I would particularly like to re-write the C layer's handling of Oracle  
object types to support better Oracle 9 and 10 usages -- in particular,  
I think it would be great to be able to access Oracle objects as python  
objects.  It's do-able, but *MY* need to do it is zilch, and without  
that self-itch to scratch... well...

Glad the hackish workaround for setoutputsize worked.

On Dec 10, 2004, at 9:49 AM, John Ziniti wrote:

> Matthew T. Kromer wrote:
>> One thing you should be able to do is grab the procedure's _cursor   
>> attribute and call setoutputsize on it, e.g.
>> curs.procedure.generations.JAVAMARKER_INSERT_PROC._cursor.setoutputsiz 
>> e( 11,80000)
> w00t!  It worked.  Thanks, Matt.  Just to note, though, that the
> numbering for the "column" parameter starts at "0", so in this case,
> it would be 10.
> Thanks again, though.
>> But that's kind of disturbing, I'll admit.
> Ehhh ... I've seen uglier kludges.
> I owe you another one.
> John

More information about the Zope-DB mailing list