[Zope-DB] insert failing without raising exception: postgresql, psycopg

freeman at tllc.com freeman at tllc.com
Wed Nov 23 09:51:25 EST 2005

Dieter Maurer <dieter at handshake.de> wrote:

> freeman at tllc.com wrote at 2005-11-22 03:27 -0800:
> >Problem:
> >	Database inserts that worked previously are now failing,
> >	without raising exceptions!
> I expect that something in your application catches exceptions.
> To verify this, I would add logging to "ZPsycopgDA" (indeed,
> I did in our version of it) and look at the logs.

I regret that I have not yet learned how to "add logging" to
ZPsycopgDA, and will appreciate learning how to do so.

In the meantime, I've solved my immediate problem by learning
how to look at the postgresql logs (in /var/postgresql/logfile)

There I saw the postgresql error messages.

I then enabled logging of sql statements (temporarily), by
editing /var/postgresql/data/postgresql.conf, and learned 
ust why postgresql was refusing to insert the data.

In the process I verified that insert exceptions are not
currently noticed by zope, as I have it configured, while
postgresql syntax errors are noticed by zope.

Maybe insert errors never were noticed by zope, and I 
simply never noticed before...

- Jerome

More information about the Zope-DB mailing list