Solved: [Zope-DB] psycopg + zope problem

Martin Konicek markon at
Wed Sep 7 16:48:30 EDT 2005


finally problem has been solved! :-) I've zope in two directories, not
only in /var/lib but also in /usr/lib.

"zopectl show"

zdctl/zdrun options:
schemafile:   '/usr/lib/zope/lib/python/Zope2/Startup/zopeschema.xml'
configfile:   '/var/lib/zope/etc/zope.conf'
interactive:  1
default_to_interactive: 1
zdrun:        '/usr/lib/zope/lib/python/zdaemon/'
python:       '/usr/bin/python'
program:      ['/var/lib/zope/bin/runzope']
backofflimit: 10
daemon:       1
forever:      0
sockname:     '/var/lib/zope/var/zopectlsock'
exitcodes:    [0, 2]
user:         None
umask:        022
directory:    '/var/lib/zope'
logfile:      '/var/lib/zope/log/event.log'
hang_around:  0

Problem was that in manual is nothing written about how to found in
which directory is zope installed, or which config file you have to

I would be really usefull to write something like this:
* run zopectl show
* place in program dir
* check logfile


More information about the Zope-DB mailing list