[ZWeb] Yet Another Packing Saga.

ethan mindlace fremen mindlace@imeme.net
Tue, 25 Jul 2000 04:29:28 -0400

Got home this evening, had some ideas for the Products page, tried to
recatalog the SiteIndex.  Got error[11] (or was it [13]): no space on

So I popped a widget, then wandered over to zope.org to check it out. 
Mysteriously, it didn't seem like it was at 100%, but more like 89%... 
Then I observe the 1,733.9 MB Data.fs and start to worry (needlessly, as
anyone more gifted at math than I will tell you) about the 2 GB issue.

I move some stuff around including 1 gigabyte worth of apache log
files.  Hopefully that didn't mess anything up irretrievably.

There's roughly 2 gigabytes of availiable space on the partition. I try
to pack, and get "no space on device".  Joy.  It's approximately 1 AM. 
It seems bleak, but I notice a post from Chris McDonough, the resident
insomniac, on zope@zope.org not 30 minutes ago.

I interrupt his ceiling meditations, and he helps me calm down a bit. 
We look around for solutions.

Many fun things were tried, but the eventual solution was liberal use of
rm -rf.  If anyone had anything important in the area, please check to
see if it's still alive.

Anyway, my campaign of devastation managed to free up 3.05 GB, which
allowed the packing to ensue!  However, having found out the magic word
"SUPPRESS_ACCESSRULE" from email, yet not reading thouroughly for the
further incantation "SUPPRESS_SITEROOT", I called it straight from the
url (as any generated URLS were wrong- I was outside of Apache at this
point, in order to ensure that the ZODB didn't grow any further).

So I packed to 0 days.  Everything was peachy!  I wanted to do the job
right, though, so I replaced Data.fs with Data.fs.old, and started
packing at 10 days.

Restart, and ieee!  index_html errors with:

"Oversize int too long to convert"

Traceback suggested it was mad at the ZWN.  Other pages worked, so I
went into management, and the ZWN- though it showed in the interface-
was effectively not there.

I copied Data.fs to my directory as Data.fs.fubar, re-ran the pack on
the Data.fs.old to 0 days (which knocks it down to 473 MB) and that, my
friends, is the state of Zope.org this fine morning.