[ZWeb] Yet Another Packing Saga.

Jim Fulton jim@digicool.com
Wed, 26 Jul 2000 08:28:05 -0400

ethan mindlace fremen wrote:
> Got home this evening, had some ideas for the Products page, tried to
> recatalog the SiteIndex.  Got error[11] (or was it [13]): no space on
> device.

Note that recataloging can use alot of temporart file space.
It is likely that this is what you ran out of.

> So I popped a widget, then wandered over to zope.org to check it out.
> Mysteriously, it didn't seem like it was at 100%, but more like 89%...

Because you ran out of temporary space. Are we still providing an environment
variable to control where temporary files get created?

> Then I observe the 1,733.9 MB Data.fs and start to worry (needlessly, as
> anyone more gifted at math than I will tell you) about the 2 GB issue.
> I move some stuff around including 1 gigabyte worth of apache log
> files.  Hopefully that didn't mess anything up irretrievably.

Damn, we should have gotten a bigger disk a *long* time ago.
> There's roughly 2 gigabytes of availiable space on the partition. I try
> to pack, and get "no space on device".  Joy.

Hm. That's odd.

>  It's approximately 1 AM.
> It seems bleak, but I notice a post from Chris McDonough, the resident
> insomniac, on zope@zope.org not 30 minutes ago.
> I interrupt his ceiling meditations, and he helps me calm down a bit.
> We look around for solutions.
> Many fun things were tried, but the eventual solution was liberal use of
> rm -rf.  If anyone had anything important in the area, please check to
> see if it's still alive.
> Anyway, my campaign of devastation managed to free up 3.05 GB, which
> allowed the packing to ensue!  However, having found out the magic word
> "SUPPRESS_ACCESSRULE" from email, yet not reading thouroughly for the
> further incantation "SUPPRESS_SITEROOT", I called it straight from the
> url (as any generated URLS were wrong- I was outside of Apache at this
> point, in order to ensure that the ZODB didn't grow any further).

I have no idea what this is about.
> So I packed to 0 days.  Everything was peachy!  I wanted to do the job
> right, though, so I replaced Data.fs with Data.fs.old, and started
> packing at 10 days.
> Restart, and ieee!  index_html errors with:
> "Oversize int too long to convert"
> Traceback suggested it was mad at the ZWN.  Other pages worked, so I
> went into management, and the ZWN- though it showed in the interface-
> was effectively not there.

There isn't enough here for me to add anything useful.
> I copied Data.fs to my directory as Data.fs.fubar, re-ran the pack on
> the Data.fs.old to 0 days (which knocks it down to 473 MB) and that, my
> friends, is the state of Zope.org this fine morning.

Does that mean that Zope.Org is unpacked? Or that it was packed to 0 
days.  If the former, I suggest we make a copy of the site and look
at the result of packing to 10 days to see what went on.


Jim Fulton           mailto:jim@digicool.com   Python Powered!        
Technical Director   (888) 344-4332            http://www.python.org  
Digital Creations    http://www.digicool.com   http://www.zope.org    

Under US Code Title 47, Sec.227(b)(1)(C), Sec.227(a)(2)(B) This email
address may not be added to any commercial mail list with out my
permission.  Violation of my privacy with advertising or SPAM will
result in a suit for a MINIMUM of $500 damages/incident, $1500 for