[Zope] Annoying ambiguous name

Peter Bengtsson mail@peterbe.com
Sat, 04 May 2002 17:10:57 +0100


I define a method like this:

ListIssues = PageTemplateFile('zpt/ListIssues', globals(), 
__name__='ListIssues')
Then I want to make a shortcut to that method like this:
listissues = ListIssues

But then I get that annoying message::

2002-05-04T16:04:13 PROBLEM(100) Init Ambiguous name for method of 
Products.IssueTrackerProduct.IssueTracker.IssueTracker: "ListIssues" != 
"listissues"

How do I get this right??


I also tried (outside the class):

IssueTracker.__dict__['listissues'] = IssueTracker.ListIssues
but still the same old error.

Anybody knows how to solve this?


Peter