[Zope] Tutorial Problems

Xavier Balling xballs at gmail.com
Mon Nov 12 19:45:18 EST 2007

I am a newbie to Zope and am evaluating it for a project but I am having a
basic problem getting it to work properly.  Any hints or advice would be
helpful. I have searched online for similar problems to no avail.

I have installed on a windows platform here are the specifics:

Zope Version

 (Zope 2.10.5-final, python 2.4.4, win32)

Python Version

 2.4.4 (#71, Oct 18 2006, 08:34:43) [MSC v.1310 32 bit (Intel)]

  System Platform










  Network Services

 ZServer.HTTPServer.zhttp_server (Port: 8080)

Although the ZMI works, I login with no errors,  Products and/or Objects
that should be accessed from a can URL can't :

  - i.e. Zoo Object Folder created per the Zope Book 2.6 (
http://localhost:8080/Zoo  ) - I get the following error

 You have not created any users in this Zope instance. In order to log in
and manage this Zope instance, you'll need to add an adminstrative user

If you're running Zope on UNIX or Linux, you can create an administrative
user account via the "zopectl adduser" command from a shell. *Note: You'll
need to shut Zope itself down before "zopectl adduser" will work. Restart
Zope after executing this command in order to log in.*

If you're running Zope on Windows, you'll need to use the "zpasswd.py"
utility in your Zope installation's "bin" directory at *
C:\Zope\2.10.5\Zope\bin* to create a file named *inituser* in your Zope
instance home at *C:\Zope\Instance\2.10.5* that contains the initial
administrative username and password.

  -  i.e. Silva ( http://localhost:8080/Zoo  ) - loaded to the Products
directory - Silva products show up in the products folder and I could find
no errors in log files.

Site Error

An error was encountered while publishing this resource.

*Resource not found*
Sorry, the requested resource does not exist.

Check the URL and try again.

*Resource:* Silva GET

- I also tried the Hello world tutorial on Zope3 and had the same result.
"Resource Not Found"

*Secondary Problem *

b) The History Tab described in the "Using the Zope Management Interface" (
figure 3.8 ) does not exist
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope/attachments/20071112/d0f99e6f/attachment.htm

More information about the Zope mailing list