[Zope] configure.zcml missing

Tracy R Reed treed at ultraviolet.org
Sun Nov 18 02:22:33 EST 2007

I originally sent this to the plone-users list but nobody replied and it
seems to be more of a zope-level problem anyway:

I am trying to upgrade my instance from Plone 2.5.2 to 3.0.3 and I am having
trouble. Been trying to do this upgrade off and on for the last two weeks.
I have tried many things but if I just follow the instructions in the
UPGRADE.txt file I am told to install the new plone, copy my Data.fs into
it, start the instance, and then run the portal migration. So I do all of
that and get <broken weblog> because I did not have my products
(specifically Quills) installed in the new instance and the quills blog is
my main page. So I shut down the instance, copied in Quills and its
dependencies, started the instance, and went to view my site. This is what
I saw:


I notice that the first thing in that mess of an error page says "No
traversable adapter found". I googled for this and found:


I downloaded my Plone 3.0.3 from plone.org in the form of the Unified
Installer. It installed my plone, zope, python, etc. I checked and setup
tools are included. So that shouldn't be the problem in my case.

Then I found this:


So I started zope in the foreground and encountered this error:


Which seems to ultimately say that it couldn't find

And sure enough it doesn't exist. I'm not sure where to go from here. I
have tried this install many different times in many ways on two different
machines (CentOS 5 and Fedora 6) and haven't had much success.

Any tips on how to resolve this would be greatly appreciated!

Version and config info copied from control panel:

   Zope Version
(Zope 2.10.5-final, python 2.4.4, linux2)
Python Version
2.4.4 (#1, Nov 17 2007, 02:15:13) [GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
System Platform
Network Services
ZServer.HTTPServer.zhttp_server (Port: 8080)
Process Id
28942 (-1253962864)
Running For
21 hours 47 min 26 sec

Tracy R Reed                  Read my blog at http://ultraviolet.org
Key fingerprint = D4A8 4860 535C ABF8 BA97  25A6 F4F2 1829 9615 02AD
Non-GPG signed mail gets read only if I can find it among the spam.

More information about the Zope mailing list