[Zope] problem authenticating, even with emergency user

Jens Vagelpohl jens at dataflake.org
Thu Jan 17 09:00:40 EST 2008

On Jan 17, 2008, at 14:39 , Ben Bartrum wrote:

> Hello
> A Zope site which is running fine, is refusing all authentication  
> with the error below.   I have tried the emergency user and  
> restarted Zope, but the emergency user gets the same error:
> Site Error
> An error was encountered while publishing this resource.
> AttributeError
> Sorry, a site error occurred.
> Traceback (innermost last):
> Module ZPublisher.Publish, line 188, in publish_module_standard
> Module Products.PlacelessTranslationService.PatchStringIO, line 51,  
> in new_publish
> Module ZPublisher.Publish, line 145, in publish
> Module Zope2.App.startup, line 222, in zpublisher_exception_hook
> Module ZPublisher.Publish, line 105, in publish
> Module ZPublisher.BaseRequest, line 446, in traverse
> Module ZPublisher.BaseRequest, line 550, in old_validation
> AttributeError: __getitem__ (Also, the following error occurred  
> while attempting to render the standard error message, please see  
> the event log for full details: getUserById)

I bet you're running a non-standard user folder, and for some reason  
the user folder instance is broken. If you can't find why it is broken  
and the broken user folder is at the root of your Zope instance then  
fixing it would involve work in the debugger to delete the old one and  
create a new standard user folder.


More information about the Zope mailing list