[Zope] strange database read conflict error

Dragos Chirila objectvalues at gmail.com
Fri Aug 28 05:01:00 EDT 2009

Hello everyone,

I have a question regarding a database read conflict error. I would
appreciate any thoughts on this issue.

I am using Zope, Python 2.3.7 with a ZEO server and 4
clients for 6 months now. I have noticed that the event.log is filled
with read conflict errors like the one below:

2009-08-28T10:29:26 INFO ZODB.Conflict database read conflict error
(oid 0x09, class Products.Transience.Transience.Increaser) at
(21 conflicts, of which 0 were unresolved, since startup at Thu Aug 27
15:25:02 2009)

This URL of the object is
http://metropotam.ro/Opera/loc4769172835-Ateneul-Roman . We have
around 2000 objects of the same type and this is *the only one* that
generates read conflict errors.

I have tried a few things:

1.	Edit object and recatalog it
2.	Rename it
3.	Delete object, pack database, create a new object and then rename
it to keep the URL alive
4.	checked the data.fs and got no errors (fstest.py)

None of the above solved the problem; I still get a lot of conflicts.

Is there a way to fix this? I found it very strange that I get
conflicts only for this object and for no other of the same type, even
in the same folder...

Thank you,
Dragos Chirila

More information about the Zope mailing list