[Zope] strange database read conflict error

Dragos Chirila objectvalues at gmail.com
Fri Aug 28 05:28:41 EDT 2009


Than you for your response. Please find below a few things:

- I give up using sessions in the website's front and years ago :)
There is only one page left that is using them, when u subscribe to
our newsletter but I don't think that this affects because is used

- I am using Yahoo Maps Ajax API to display maps; also some ajax calls
for our build in chat (only for logged users)

So if the things above are causing read conflicts why only for this
particular object? There is nothing special or different with this

Thanks again,

On Fri, Aug 28, 2009 at 12:19 PM, Peter Bengtsson<peterbe at gmail.com> wrote:
> The fact that the class is Products.Transience.Transience.Increaser
> makes me suspect that you're using sessions and within the same
> session you make too many read requests to the ZODB. When the load is
> too high, after a certain amount of attempts Zope will say, "piss off!
> ...for a while and come back later". So it comes back later and works
> fine.
> Are you using lots of AJAX requests? That can sometimes cause read
> conflict errors.
> 2009/8/28 Dragos Chirila <objectvalues at gmail.com>:
>> Hello everyone,
>> I have a question regarding a database read conflict error. I would
>> appreciate any thoughts on this issue.
>> I am using Zope, Python 2.3.7 with a ZEO server and 4
>> clients for 6 months now. I have noticed that the event.log is filled
>> with read conflict errors like the one below:
>> 2009-08-28T10:29:26 INFO ZODB.Conflict database read conflict error
>> (oid 0x09, class Products.Transience.Transience.Increaser) at
>> /VirtualHostBase/http/metropotam.ro:80/metropotam/VirtualHostRoot/Opera/loc4769172835-Ateneul-Roman/
>> (21 conflicts, of which 0 were unresolved, since startup at Thu Aug 27
>> 15:25:02 2009)
>> This URL of the object is
>> http://metropotam.ro/Opera/loc4769172835-Ateneul-Roman . We have
>> around 2000 objects of the same type and this is *the only one* that
>> generates read conflict errors.
>> I have tried a few things:
>> 1.      Edit object and recatalog it
>> 2.      Rename it
>> 3.      Delete object, pack database, create a new object and then rename
>> it to keep the URL alive
>> 4.      checked the data.fs and got no errors (fstest.py)
>> None of the above solved the problem; I still get a lot of conflicts.
>> Is there a way to fix this? I found it very strange that I get
>> conflicts only for this object and for no other of the same type, even
>> in the same folder...
>> Thank you,
>> Dragos Chirila
>> _______________________________________________
>> Zope maillist  -  Zope at zope.org
>> https://mail.zope.org/mailman/listinfo/zope
>> **   No cross posts or HTML encoding!  **
>> (Related lists -
>>  https://mail.zope.org/mailman/listinfo/zope-announce
>>  https://mail.zope.org/mailman/listinfo/zope-dev )
> --
> Peter Bengtsson,
> work www.fry-it.com
> home www.peterbe.com
> hobby www.issuetrackerproduct.com
> fun crosstips.org

Dragos Chirila
objectValues at gmail.com
(+4) 0722 395375

More information about the Zope mailing list