[Zope] Zope 2.12.2 & IContentType

Roberto Allende rover at menttes.com
Tue Dec 8 20:56:31 EST 2009


I'm trying to make a very simple package in Zope 2.12.2 and i'm trying 
to configure a content type with:


and i'm getting:
ConfigurationError: ('Invalid value for', 'package', "ImportError: 
Couldn't import zope.app.content, No module named content")

I tried including "zope.app.content" and i'm getting 'ImportError: 
Module zope.app has no global content' error.

Reading zope.app.folder's code I saw it includes "zope.site", so i tried 
with it and it doesn't work neither because it gives ConfigurationError: 
('Invalid directive', u'factory').

I used to do stuff like this with zope 2.9 without problems and also 
tried with philipp's book samples getting same results, wich is the code 
i pasted here btw, then i guess it could be smt deprecated in Zope 2.12.

I believe I should be able to solve this going deeper with zcml 
machinery, smt i've to do someday anyway :), but if you're familiar with 
the problem or can give me any hint, it will be very appreciated.

Kind Regards


More information about the Zope mailing list