[Zope] VHM missing 'mappings' tab in Safari 4 - just me?

Tres Seaver tseaver at palladion.com
Fri Jun 19 00:12:25 EDT 2009

Hash: SHA1

Sean Fulmer wrote:
> Hi all - I recently upgraded to Safari 4 on Leopard 10.5.7. Since doing so, my
> Zopes' VHM objects no longer show me the 'Mappings' (mange_edit) tab. The same
> thing happens in recent WebKit nightlies.
> It does not appear to be a rendering bug - the tab isn't even the markup.
> Other browsers I've tried (Firefox 3.0.11, Opera 9.65, Camino 2.0b3) don't
> exhibit the problem.
> I've checked this on Zope 2.8.5 and 2.10.5 with the same result.
> I realize this is more of a Safari problem than a Zope problem, but I was just
> curious if anyone else had run into this, and if so, could suggest a solution.

This smells like a permissions problem, and particularly the "Add Site
Roots" permission.  Is "Site Root" in the ZMI add menu when you use
Safari?  in Firefox?  And are you double-sure that you are logging in
with the same credentials in both browsers? To double check, don't let
either browser supply the password:  type it yourself.

- --
Tres Seaver          +1 540-429-0999          tseaver at palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Zope mailing list