[Zope] zope2 2.12 installation on Windows 7

Tres Seaver tseaver at palladion.com
Wed Sep 8 07:36:11 EDT 2010

Hash: SHA1

Dragos Chirila wrote:
> Hi everybody,
> I'm having some problems when I have to run a zope2 2.12 instance. Here are
> the steps:
> 1. fresh install of Python 2.6.3 - python-2.6.3.msi
> 2. install pywin - pywin32-214.win32-py2.6.exe
> 3. install setup tools - setuptools-0.6c11.win32-py2.6.exe
> 4. install Zope2 using easy_install from egg - Zope2-2.12.0-py2.6-win32.egg
> 5. create a new instance using mkzopeinstance.exe
> Until here, everything worked great. Now , I modify the zope.conf to turn
> the debug on and try to run the created instance. Here is the error that I
> receive:


> I took the above steps twice, second time after removing everything and
> still got the same error. I do not install any additional zope product or
> python package, just using the zope2 installation.
> I will appreciate any hints or ideas on this problem.

Your traceback shows conflicting ZCML registrations between the version
of zope.formlib you are using (4.0.4, very recent) and the version of
Zope2 you are using (2.12.0, much older).  Please try updating to the
latest version of Zope2 (2.12.10), which pins the zope.formlib
dependency to version 3.7.0.  E.g.:

 bin\easy_install -U Zope2

You may need to remove the zope.formlib 4.0.4 egg first.

- --
Tres Seaver          +1 540-429-0999          tseaver at palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Zope mailing list