[Zope] Issues with programmatically deleting objects

niveditha j niveditha.jjj at gmail.com
Thu Sep 15 07:29:31 EST 2011

Hi All,

I am new to Zope, using Zope 2.7 and wrote a "Script Python" to delete
objects programatically(used for bulk delete).


After I execute the script using the Test button of the ZMI, the objects are
getting deleted properly.

But in the Undo tab, I am not able to see the transaction history
(/mysite/path/manage_delObjects by *niv)*

When I tried to add transaction.commit() the ZMI is asking for credentials.

1. How do I get the transaction recorded using Script Python?
2. Are there any other ways to achieve the same?

3. Another issue is, when I tried to invoke the delete Script Python from an
external python script using xmlrpc it threw a xmlrpclib.ProtocolError 401
Unauthorized Error. Is it because there is a manage_delObjects call?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope/attachments/20110915/5ef25b25/attachment.html 

More information about the Zope mailing list