[Zope] Zope instance not serving website - Site Error

Matthew Moore matt at smtl.co.uk
Thu Feb 2 14:23:28 UTC 2012

Hash: SHA1

On 02/02/12 13:44, Niels Dettenbach (Syndicat IT&Internet) wrote:
> Matthew Moore <matt at smtl.co.uk> schrieb:
> >>> worked fine. It's only since the server crashed it's not worked.
> Just to make shure:
> Do you have any backup from the "var" stuff of the Zope Instance (i.e.
Data.fs* aso.)? Could you try to stop Zope, swap the backup in and try
to start (shure, make a current backup of var before you swap in...)?
May be Zope did something rolled within your ZODB and changed ZODB
content in any way i/you can't see on a first view...
> I'm not a Plone geek but one possibl point could be somekind of update
from/by zc.buildout you possibly runned in the past?
> Could you get any copy/backup of your full Zope instance (including
external / local fs dirs if happen) and try so start that (you have to
fiddle with proper pathes within etc, bin and your (former) local fs
objects within zodb?

I've already tried the following:

Secured current non working zope db and instance
Restored just the Data.fs* files (same error)
Restored whole instance (tried from two different backup sets in

I think that pretty much covers it.

I have full backups of the whole server, so can try restoring other
sections, just don't really know enough about zope/plone to know what to
restore.  I store the instance in /usr/local/instances/zope-instance, so
I just copied the whole 'zope-instance' folder over.

I don't think the people who put the content on the website change it
very often, so I can go to even older backups if needed, but I don't
think it'll work.


- -- 
Matthew Moore
Surgical Materials Testing Laboratory
System Administrator
Telephone: +44 (0)1656 752165
Email: matt at smtl.co.uk
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Zope mailing list