[Zope] Zope instance not serving website - Site Error

Matthew Moore matt at smtl.co.uk
Tue Feb 7 12:08:22 UTC 2012

On 03/02/12 10:56, Sascha Gottfried wrote:
> Am 02.02.2012 14:12, schrieb Matthew Moore:
>> On 02/02/12 11:43, Sascha Gottfried wrote:
>>> Matthew,
>>>> Sascha,
>>>>> you probably need to know the concepts of Zope Through-the-web
>>>>> (TTW) and Filesystem (FS) Product Coding.
>>>>> Some templates, scripts are in the ZODB and editable via ZMI - the
>>>>> recommended style for a not so recent Zope version is using FS
>>>>> Zope Products. Please identify the zope version by using the
>>>>> ZMI-ControlPanel.
>>>> I'm reading up on the TTW and FS stuff.  Any articles/pages you
>>>> particulary recommend?
>>> http://readthedocs.org/docs/collective-docs/en/latest/
>>>> I can't edit anything using the ZMI, when I click on the pages in
>>>> 'Content' I get the error message.
>>>> The version line from the error log is this - 'Zope/(Zope
>>>> 2.9.4-final, python 2.4.3, linux2) ZServer/1.1 Plone/2.5'
>>>>> Please compare the way you start the zope instance with the way
>>>>> your former colleague did it.
>>>> I'm not sure what the previous guy did, but I've used the init
>>>> script (/etc/init.d/zope start) and the zopectl script in the bin/
>>>> in the instance.  All methods of starting give the same errors.  I
>>>> have had to restart zope before now, and I've always used zopectl
>>>> and that's worked fine.  It's only since the server crashed it's
>>>> not worked.  I'd only used zopectl fg so I could see what was
>>>> happening on startup.  Currently the site (www.legulcerforum.org)
>>>> is started using the init script.
>>>>> Identify if you are using a custom developed  Zope Product with
>>>>> templates and a 'main_template' and optionally a 'folder_listing'
>>>>> Zope Page Template or similar. Find them by searching in the
>>>>> filesystem ('Products' Folder is one option) and in the ZMI and
>>>>> tell us the location if you find them.
>>>> I don't think it's custom, I've put a list of the Products
>>>> directory on pastebin:
>>>> http://pastebin.com/cftnjbgZ
>>>> I think it's pretty much just plone.
>>> Please go for portal_skins tool in ZMI , identify the current skin
>>> and check that the chosen skin lists several layers. These layers
>>> consist of several FS Directory View belonging to several products
>>> and their skin directories.
>>> If you are using Plone 2.5 use this book. There is also a HTML
>>> version free available in the web.
>>> http://plone.org/documentation/kb/definitive-guide
>>> Consult the chapter about skinning Plone, the 'custom' folder and
>>> the setup of skins and layers.
>> Thanks for all the links.
>> I'm not 100% as to exactly which one is the skin that's in use, but
>> all of the folders in plone_skins do have files and folders in them. 
>> The one that's most likely to be it (called custom and not changed
>> since 2006, which is when the site was installed).  Has all the
>> logos, a main_template (which looks ok as far as I can tell) and a
>> css file as well as a base_properties directory.
> Now you are scratching below the surface. All folders in plone_skins
> are registered FS Directory Views (FSDV). The current plone skin
> layers a couple of skin folders to make them available to your Plone
> Site via Acquisition at portal root URL. If the 'custom' folder is not
> listed in the list of layers of your current skin - Plone probably can
> not find the 'main_template' by calling context.main_template().
> Usually the 'custom' folder is the topmost layer in a skin - what
> means that all resources in there a hiding resources with the same
> name. This way you can override the standard main_template ZPT shipped
> in in plone_skins.
> Just another hint. Some run-time made configuration in ZMI is set back
> to default when you restart the Zope instance. That's why a backup
> will not always restore the a Plone site. That's why it is evil to do
> that - because it is not done in code on the file system - and you
> have to remember. Welcome to generic-setup stuff.
> Please investigate and come back.
> By the way - to get more specific support, consider to ask on
> 'plone-users' mailing list. Check this list as another source of help.
> At current  state you can provide much detailed information regarding
> your error.
> Cheers Sscha

Sorry for missing the Zope-users list.  I'd been looking for it, but had
obviously missed it.

I've 'fixed' the problem for me by simply moving the site to our main
CMS, which is properly maintained and updated.  I had been planning on
moving the site over to it anyway in the long run, this has just forced
my hand.  I've spent too much time on trying to restore a site that
doesn't seem like it's going to be quick or easy to restore.  I may come
back to it and see if I can fix it, but for now, I'm going to leave it.

Many thanks for the prompt help that you've given, I really appreciate it.


Matthew Moore
Surgical Materials Testing Laboratory
System Administrator
Telephone: +44 (0)1656 752165
Email: matt at smtl.co.uk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.zope.org/pipermail/zope/attachments/20120207/7ead07f9/attachment.html>

More information about the Zope mailing list