[Zope3-Users] Re: zwiki addon

Derrick Hudson dman at dman13.dyndns.org
Fri Mar 18 12:14:12 EST 2005

On Thu, Mar 17, 2005 at 07:58:16PM -0500, Rob wrote:
| I have it in /var/lib/zope3/main/lib/python:
| /var/lib/zope3/main
| [root at casero main]# ls -al lib/python
| total 16
| drwxr-xr-x  3 root root 4096 Mar 16 20:51 .
| drwxr-xr-x  3 root root 4096 Mar 16 20:26 ..
| -rw-r--r--  1 root root  310 May 14  2004 README.txt
| drwxr-xr-x  4 root root 4096 Mar 16 20:51 zwiki
| [root at casero main]#


| Copying the configure.zcml is what AddonPackageInstall url said to do if I
| installed it in an instance. Well, maybe not in so many words:
| "
| a.. Any new Zope instance will now have this package at its disposal. If you
| want to make the package available to existent Zope 3 instances, then you
| have to manually install the '-configure.zcml' file to
| '/etc/package-includes'.
| "


I suggest filing a low-priority bug report to the effect that addon
installation is confusing to people inexperienced with zope3.  If you
don't, then I may do that sooner or later (probably later :-/).

Notice the "-" in '-configure.zcml' in the text you quoted above.
That is referring to a file not actually included in the zwiki
distribution.  The idea is that zwiki will have a
"zwiki-configure.zcml" file with that <include> line and you, as an
administrator, will merely copy or link to that file.  The confusing
aspect for you is the naming similarity with the "configure.zcml"
which belongs where it is in the package.

| While it might mean use an 'include' element in zwiki-configure.zcml, that's
| what I tried first.

I noticed that you said that in the first post.  Without having
actually seen your system at that time, here is my interpretation of
that scenario, based on your description and the error message :
    1)  you configured zope correct with the zcml file
    2)  'zwiki' wasn't on the python path, or perhaps (somehow) the
            __init__.py file was missing

#2 is not true, at least with the information you presented at the top
of your second message.

| Here's the sys.path (I added the print just before the import/main call):
| [root at casero bin]# ./zopectl stop
| ['/var/lib/zope3/main/lib/python', '/opt/zope3/lib/python',
| '/var/lib/zope3/main/bin', '/usr/lib/python23.zip', '/usr/lib/python2.3',
| '/usr/lib/python2.3/plat-linux2', '/usr/lib/python2.3/lib-tk',
| '/usr/lib/python2.3/lib-dynload', '/usr/lib/python2.3/site-packages',
| '/usr/lib/python2.3/site-packages/PIL']

That looks good.  The two key points, for zope as opposed to any other
python application on your system, are the items
'/var/lib/zope3/main/lib/python' and '/opt/zope3/lib/python'.  Those
are the two suitable locations for installing z3 addons on your

| Well. I moved zwiki-configure.zcml (the full version) and put the 'include'
| directive in it instead and it worked fine

That's good.

| (after the first install was
| already done anyway..meaning it may not be reading it again?).

Zope reads all the zcml files at every startup.

| Maybe someday I'll fresh install and try again...or see what some of
| the other addon packages do.

| Thanks for the info. It certainly helps to confirm how packages should be
| installed.

You're welcome.


(A)bort, (R)etry, (T)ake down entire network?
www: http://dman13.dyndns.org/~dman/            jabber: dman at dman13.dyndns.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mail.zope.org/pipermail/zope3-users/attachments/20050318/1f73cd45/attachment.bin

More information about the Zope3-users mailing list