[Grok-dev] Re: grok.View: Self-submitting forms, redirect, and before()

Philipp von Weitershausen philipp at weitershausen.de
Wed Jan 10 13:35:02 EST 2007

On 10 Jan 2007, at 19:32 , Jegenye 2001 Bt (Miklós Prisznyák) wrote:
> 2007/1/10, Philipp von Weitershausen <philipp at weitershausen.de>:
>> > Basically, we rename before() to update() and add the semantics  
>> that a
>> > redirect caused in update() will stop all further rendering.
>> Done. It's checked in. I also updated my blog entry:
> Hi all,
> While I do like the change in semantics, I'm really sorry but I think
> "update" is a more confusing name, to me at least, than "before" was
> for a method which is executed before the template is rendered.
> I'd suggest perhaps "doBefore" or "doBeforeRender" or anything like  
> that.
> "Update" doesn't imply at all when this thing is executed, before or
> after the show (which must go on, of course :& ).

Perhaps, though update() is a common idiom frequently used in Zope 3  
(e.g. zope.formlib, zope.contentprovider).

More information about the Grok-dev mailing list