[Zope-DB] ImportError: libmysqlclient_r.so.15

Michele Marcionelli michele.marcionelli at math.ethz.ch
Thu Nov 8 02:33:01 EST 2007

Hello Charlie

no... it's not a permissions problem (and also not a SELinux  
problem). I just found a solution for the problem

echo "/usr/local/lib/mysql" > /etc/ld.so.conf.d/mysql.conf

But I still wonder why the LD_LIBRARY_PATH variable is ignored!?

Any idea?

Thank you,

On 07.11.2007, at 21:41, Charlie Clark wrote:

> Am 07.11.2007, 21:31 Uhr, schrieb Michele Marcionelli  
> <michele.marcionelli at math.ethz.ch>:
>> If I do the same after setting the LD_LIBRARY_PATH to /usr/local/ 
>> lib/mysql, I did not get error messages anymore!
>>  Now the problem: I included the LD_LIBRARY_PATH to my startup- 
>> script zopectl (see below) but I still get the same error message  
>> in the event.log file:
> Sounds like a permissions problem: the Zope user might not be  
> allowed to access /usr/local/lib/mysql.
> Charlie

More information about the Zope-DB mailing list