[Zope] Troubles with a Zope-2.7.7-final instance

Sascha Welter zopelist at betabug.ch
Mon Mar 17 13:35:52 CET 2014

(Mon, Mar 17, 2014 at 12:00:01PM +0100) zope-request at zope.org wrote/schrieb/egrapse:
> Date: Mon, 17 Mar 2014 09:05:00 +0100
> From: Herbert Liechti <xherbie at gmail.com>
> I have some troubles with a customers system whos maintainer is no longer
> available. There was a zope 2.7.7 instance running there until last week.
> The system was rebooted after a long time an the instance did not come back
> online.
> I tried different things and after all I compiled python2.4 and all
> dependend stuff (I found all sources on the system). Now the instance is
> starting up with zopectl start. Unfortunately after a few minutes the
> instance dies without any messages in the log files. I tried to increase
> the log level but it has no effect.
> The instance should listen on port 8080. But I never encountered a listen
> on that port when I start up zope. I have no idea where to search now.

First step, start it with `zopectl fg` in the foreground to be able to
see any error messages popping up. If it takes a few minutes, it might
be reindexing the db on startup and then running into a problem.
Whatever it is, "fg" gives you a chance to see more.

> I'm not very familiar with zope. Any help is much appreciated.

Here are some hints that I wrote down a while ago:


More information about the Zope mailing list